<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head profile="http://gmpg.org/xfn/11">

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en" />
<meta name="verify-v1" content="7XvBEj6Tw9dyXjHST/9sgRGxGymxFdHIZsM6Ob/xo5E=" />
<meta name="viewport" content="width=436,user-scalable=yes" />


<link rel="Shortcut Icon" href="http://racenews.co.uk/wp-content/themes/organic_business/images/favicon.ico" type="image/x-icon" />

<link rel="stylesheet" href="http://racenews.co.uk/wp-content/themes/organic_business/style.css" type="text/css" media="screen" />
<style type="text/css" media="screen">

#header, #headercontent {
background-color: #f9f9f9;}
div.anythingSlider .arrow:hover, #submit:hover, #searchsubmit:hover, .reply a:hover, #content.left .feature_img:hover, #homeslider .slideinfo:hover, .launch:hover, div.anythingSlider.activeSlider .thumbNav a:hover, 
div.anythingSlider.activeSlider .thumbNav a.cur, .menu li li a:focus, .menu li li a:hover, .menu li li a:active, #header .menu .current_page_item ul li a:hover, #header .menu .current-menu-item ul li a:hover, #header .menu .current-cat ul li a:hover {
background-color: #932469;}

a, a:link, a:visited, #sidebar_right ul.menu .current_page_item a, #sidebar_right ul.menu .current-menu-item a, #sidebar_left ul.menu .current_page_item a, #sidebar_left ul.menu .current-menu-item a, #container .gform_wrapper input.button {
color: #932469;}

a:hover, #container h1 a:hover, #container h2 a:hover, #container h3 a:hover, #container h4 a:hover, #container h5 a:hover, #container h6 a:hover, #sidebar_right .widget ul li a:hover, #sidebar_left .widget ul li a:hover, #sidebar_right ul.menu li a:hover, #sidebar_left ul.menu li a:hover, #sidebar_right ul.menu li ul.sub-menu li a:hover, 
#sidebar_left ul.menu li ul.sub-menu li a:hover, #sidebar_right ul.menu .current_page_item a, #sidebar_right ul.menu .current-menu-item a, #sidebar_left ul.menu .current_page_item a, #sidebar_left ul.menu .current-menu-item a, #container .gform_wrapper input.button:hover {
color: #932469;}
</style>
<link rel="alternate" type="application/rss+xml" title="Racenews RSS Feed" href="http://racenews.co.uk/feed/" />
<link rel="alternate" type="application/atom+xml" title="Racenews Atom Feed" href="http://racenews.co.uk/feed/atom/" />
<link rel="pingback" href="http://racenews.co.uk/xmlrpc.php" />


<!-- This site is optimized with the Yoast WordPress SEO plugin v1.4.22 - http://yoast.com/wordpress/seo/ -->
<title>Laughs just holds on to take Timico-sponsored feature on Hunter Chase Evening - Racenews</title>
<link rel="canonical" href="http://racenews.co.uk/laughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Laughs just holds on to take Timico-sponsored feature on Hunter Chase Evening - Racenews" />
<meta property="og:description" content="Cheltenham Racecourse&#8217;s season concluded today, Friday, May 5, with the popular Hunter Chase Evening. The richest contest of the evening was the new £25,000 Timico Mixed Open Gold Cup Final Hunters&#8217; Chase (6.45pm), run over the Timico Cheltenham Gold Cup distance of an extended three and a quarter miles, in which Barel Of Laughs (Philip Rowley/Mr Alex Edwards, 8/13 Fav) narrowly came out on top. The 11-year-old, who finished third in the St James&#8217;s Place Foxhunter Chase at The Festival in March, travelled smoothly and went a..." />
<meta property="og:url" content="http://racenews.co.uk/laughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening/" />
<meta property="og:site_name" content="Racenews" />
<meta property="article:section" content="Cheltenham" />
<meta property="article:section" content="Racenews Live" />
<meta property="article:published_time" content="2017-05-05T20:19:51+00:00" />
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@RacenewsService"/>
<meta name="twitter:domain" content="Racenews"/>
<meta name="twitter:creator" content="@RacenewsService"/>
<!-- / Yoast WordPress SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Racenews &raquo; Feed" href="http://racenews.co.uk/feed/" />
<link rel="alternate" type="application/rss+xml" title="Racenews &raquo; Comments Feed" href="http://racenews.co.uk/comments/feed/" />
<link rel='stylesheet' id='dashicons-css'  href='http://racenews.co.uk/wp-includes/css/dashicons.min.css?ver=3.8.20' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://racenews.co.uk/wp-includes/js/thickbox/thickbox.css?ver=20131201' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-style-smoothness-css'  href='http://ajax.googleapis.com/ajax/libs/jqueryui/1.8/themes/smoothness/jquery-ui.css?ver=3.8.20' type='text/css' media='all' />
<link rel='stylesheet' id='thethe-haccordion-css'  href='http://racenews.co.uk/wp-content/plugins/thethe-tabs-and-accordions/style/thethe-haccordion.css?ver=3.8.20' type='text/css' media='all' />
<script type='text/javascript' src='http://code.jquery.com/jquery-latest.min.js?ver=latest'></script>
<script type='text/javascript' src='http://racenews.co.uk/wp-includes/js/comment-reply.min.js?ver=3.8.20'></script>
<script type='text/javascript' src='http://code.jquery.com/jquery-migrate-1.0.0.min.js?ver=3.8.20'></script>
<script type='text/javascript' src='http://racenews.co.uk/wp-content/plugins/news-ticker/cycle.js?ver=3.8.20'></script>
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jqueryui/1.8/jquery-ui.min.js?ver=3.8.20'></script>
<script type='text/javascript' src='http://racenews.co.uk/wp-content/plugins/thethe-tabs-and-accordions/style/js/thethe.toggle.js?ver=3.8.20'></script>
<script type='text/javascript' src='http://racenews.co.uk/wp-content/plugins/thethe-tabs-and-accordions/style/js/thethe.haccordion.js?ver=3.8.20'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://racenews.co.uk/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://racenews.co.uk/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 3.8.20" />
<link rel='shortlink' href='http://racenews.co.uk/?p=5485' />
<script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-40103405-1']);
_gaq.push(['_trackPageview']);
(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<style type="text/css">div.simplesocial,a.simplesocial{float:left;display:block}a.simplesocial{margin-right:5px;width:16px;height:16px}a.simplesocial:hover{margin-top:-2px}</style>
            <script language="javascript">function simplesocial(t,w,h){
            window.open(t.href, 'simplesocial', 'scrollbars=1,menubar=0,width='+w+',height='+h+',resizable=1,toolbar=0,location=0,status=0,left='+(screen.width-w)/2+',top='+(screen.height-h)/3);
            return false;}</script>
<!-- TheThe Fly Tabs-n-Accordions custom style begin //-->
<style type='text/css'>
#homeslider .slideinfo p {font-size:28px; font-family: Titillium Web; color: #3A557C;}
#homeslider .slideinfo {opacity:0.8; filter:alpha(opacity=80); height:25px; margin-top:350px;}
#homeslider .slideinfo h2 {border-right:none; font-size:28px; font-family: Titillium Web; color: #3A557C;}
#homeslider .slideinfo .morearrow {
float: right; display: none; width: 50px; height: 40px;}
.ui-widget-content {color: #333333;
	font-size: 12px;
	font-family: Tahoma, Arial, Helvetica, sans-serif;
	line-height: 20px;
	margin: 0px auto 0px;
	padding: 0px;}
</style><!-- TheThe Fly Tabs-n-Accordions custom style end //-->
<style type="text/css">
#header #title a {
background: url(http://176.32.230.11/racenews.co.uk/wp-content/uploads/2013/01/racenews_logo.png) no-repeat;
}
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url('http://176.32.230.11/racenews.co.uk/wp-content/uploads/2013/01/background_racenews.jpg'); background-repeat: no-repeat; background-position: top left; background-attachment: scroll; }
</style>
			<!-- Easy Columns 2.1.1 by Pat Friedl http://www.patrickfriedl.com -->
			<link rel="stylesheet" href="http://racenews.co.uk/wp-content/plugins/easy-columns/css/easy-columns.css" type="text/css" media="screen, projection" />
			
<script type="text/javascript" src="http://racenews.co.uk/wp-content/themes/organic_business/js/superfish/superfish.js"></script>
<script type="text/javascript" src="http://racenews.co.uk/wp-content/themes/organic_business/js/superfish/hoverIntent.js"></script>
<script type="text/javascript" src="http://racenews.co.uk/wp-content/themes/organic_business/js/jquery.anythingslider.js"></script>
<script type="text/javascript" src="http://racenews.co.uk/wp-content/themes/organic_business/js/jquery.anythingslider.video.js"></script>
<script type="text/javascript" src="http://racenews.co.uk/wp-content/themes/organic_business/js/swfobject.js"></script>

<link href='http://fonts.googleapis.com/css?family=Droid+Sans:400,700' rel='stylesheet' type='text/css'>

<script type="text/javascript">
	var $j = jQuery.noConflict();
	$j(document).ready(function () {
		$j('#slider1').anythingSlider({
			width           : 896,
			height          : 450,
			delay           : 10000,
			resumeDelay     : 10000,
			startStopped    : false,
			autoPlay        : true,
			autoPlayLocked  : false,
			easing          : "swing"				
		});
	});
</script>

<script type="text/javascript"> 
	var $j = jQuery.noConflict();
	$j(document).ready(function () {
		$j('#homeslider iframe').each(function() {
			var url = $j(this).attr("src")
			$j(this).attr("src",url+"&amp;wmode=Opaque")
		});
	});
</script>

<script type="text/javascript"> 
	var $j = jQuery.noConflict();
	$j(document).ready(function() { 
		$j('.menu').superfish(); 
	});
</script>

</head>

<body class="single single-post postid-5485 single-format-standard custom-background">

<div id="wrap">

    <div id="header">
 <!--<div id="logowrapper"><div class="logoholder"><a href="http://www.racenews.co.uk/category/racenews-live/" title="Race News Live"><img src="http://racenews.co.uk/wp-content/themes/organic_business/images/racenewslive_NTlogo.png" /></a></div></div>-->
     <div id="headerbottom">
     <div id="logowrapper">
          <div id="headerinfo">
               <!-- START TICKER VER 2.1.2 -->
<script type="text/javascript" language="javascript">
jQuery(document).ready(function(){
  jQuery('#news-ticker').cycle({ 
	 speed: 2000,
	 timeout: 4000,
	 		 height: 'auto',		 
	 	 
	 fx: 'scrollRight',
	 pause: 1,
	 containerResize: 1
  });
});
</script>
<ul id="news-ticker" style="overflow:hidden;">
     
<li>
<span class="tickerDate">May 5, 2017</span> - <span class="tickerLink"><a href="http://racenews.co.uk/laughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening/">Laughs just holds on to take Timico-sponsored feature on Hunter Chase Evening</a></span></li>

   
<li>
<span class="tickerDate">May 5, 2017</span> - <span class="tickerLink"><a href="http://racenews.co.uk/fridays-news-ahead-sundays-champions-mile-chairmans-sprint-prize/">Friday's news ahead of Sunday's Champions Mile and Chairman's Sprint Prize</a></span></li>

   
<li>
<span class="tickerDate">May 4, 2017</span> - <span class="tickerLink"><a href="http://racenews.co.uk/thursdays-news-ahead-sundays-g1-champions-mile-g1-chairmans-sprint-prize/">Thursday's news ahead of Sunday's G1 Champions Mile and G1 Chairman's Sprint Prize</a></span></li>

   
<li>
<span class="tickerDate">May 4, 2017</span> - <span class="tickerLink"><a href="http://racenews.co.uk/rowley-hoping-last-laughs-cheltenhams-hunter-chase-evening-tomorrow/">Rowley hoping to have last Laughs at Cheltenham's Hunter Chase Evening tomorrow</a></span></li>

   
<li>
<span class="tickerDate">May 3, 2017</span> - <span class="tickerLink"><a href="http://racenews.co.uk/minding-ribchester-head-21-acceptors-newburys-flat-feature-al-shaqab-lockinge-stakes/">Minding and Ribchester head 21 acceptors for Newbury's Flat feature - the Al Shaqab Lockinge Stakes</a></span></li>

</ul>
<!-- END TICKER -->
          </div></div>
    
    	<div id="headercontent">
    	
	        <div class="logo">
	            <h1 id="title"><a href="http://racenews.co.uk/" title="Home">Racenews</a></h1>
	        </div>
	        
	        <span id="navpad"></span>
	        
	        <div id="navigation">
				<div class="menu"><ul id="menu-navigation" class="menu"><li id="menu-item-461" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-461"><a href="http://racenews.co.uk/category/racenews-live/">latest news</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24"><a href="http://racenews.co.uk/promoting-racing/">promoting racing</a></li>
<li id="menu-item-23" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23"><a href="http://racenews.co.uk/clients/">our clients</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22"><a href="http://racenews.co.uk/about-us/">about us</a></li>
<li id="menu-item-21" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21"><a href="http://racenews.co.uk/contact/">contact</a></li>
</ul></div>	        </div>
        
        </div>
    </div>
    
     </div>
    <div style="clear:both;"></div>
<div id="container">

	<div class="holder">

	<div id="content" class="left">	

<p id="breadcrumbs"><span xmlns:v="http://rdf.data-vocabulary.org/#"><span typeof="v:Breadcrumb"><a href="http://racenews.co.uk" rel="v:url" property="v:title">Home</a></span> • <span typeof="v:Breadcrumb"><a href="http://racenews.co.uk/category/cheltenham/" rel="v:url" property="v:title">Cheltenham</a></span> • <span typeof="v:Breadcrumb"><span class="breadcrumb_last" property="v:title">Laughs just holds on to take Timico-sponsored feature on Hunter Chase Evening</span></span></span></p>		<div class="postarea">

			            
            <div class="posttitle">		

				<h1>Laughs just holds on to take Timico-sponsored feature on Hunter Chase Evening</h1>

                <div class="postauthor">            
                    <p>Posted by <a href="http://racenews.co.uk/author/racenews/" title="Posts by racenews" rel="author">racenews</a> on Friday, May 5, 2017 &middot; <a href="http://racenews.co.uk/laughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening/#respond">Leave a Comment</a>&nbsp;</p>
                </div>
                    
            </div>

			<div>Cheltenham Racecourse&#8217;s season concluded today, Friday, May 5, with the popular Hunter Chase Evening.</div>
<div></div>
<div>The richest contest of the evening was the new £25,000 Timico Mixed Open Gold Cup Final Hunters&#8217; Chase (6.45pm), run over the Timico Cheltenham Gold Cup distance of an extended three and a quarter miles, in which <b>Barel Of Laughs</b> (Philip Rowley/Mr Alex Edwards, 8/13 Fav) narrowly came out on top.</div>
<div></div>
<div>The 11-year-old, who finished third in the St James&#8217;s Place Foxhunter Chase at The Festival in March, travelled smoothly and went a clear lead four fences from home. He looked all set to register a comfortable victory approaching the last but faced a strong challenge from Talkonthestreet (Ian Chanin/Mr Michael Legg, 11/1) on the run-in and at the winning post held on by a diminishing short-head. There was a massive gap of 48 lengths back to the third Real Milan (Nick Jones/Mr J Jones, 8/1).</div>
<div></div>
<div>Shropshire-based Rowley commented: &#8220;Barel Of Laughs battled really well. Jumping the last I thought we had won it quite easily, but that second horse battled up the hill. At one point I thought he was going to get us on the line which was a nerve-racking moment.</div>
<div></div>
<div>&#8220;He took a bit of a flyer at the last and seemed to be doing it so easily. Alex maybe feels he hit the front a bit too soon.</div>
<div></div>
<div>&#8220;A lot of the jockeys have said they have had to keep hold of their horses because the ground is softer than ideal. It is the same for everybody.</div>
<div></div>
<div>&#8220;He came to us from Ireland and last year was quite a gentle year. We chipped away with him in points and he won a couple, then we ended up coming here for this meeting when he was second.</div>
<div></div>
<div>&#8220;He had a hobday but summered really well and all his problems seemed to iron themselves out. It was owners&#8217; wishes to aim for the Foxhunters at The Festival, which we did, and he ran a great race at 100/1 to be third beaten a neck and a neck.</div>
<div></div>
<div>&#8220;He won the Lady Dudley Cup a couple of weeks ago, which is a huge prize, and to win again today is great.</div>
<div></div>
<div>&#8220;Depending on the weather and how he comes out of tonight, he could possibly go to Stratford providing it is nice safe ground.</div>
<div></div>
<div>&#8220;It has been a fantastic season and we are so lucky to have such great support from owners.&#8221;</div>
<div></div>
<div>Favourite backers got off to the perfect start when <b>Are They Your Own</b> (Fergal O&#8217;Brien/Miss Brodie Hampson, 7/4) sauntered to a comfortable victory in the opening Brian Babbage Memorial Open Hunters&#8217; Chase (5.10pm) over an extended two miles. The nine-year-old was in command some way from home, taking up the running at the fifth fence.</div>
<div></div>
<div>Sam Cavallaro (Heidi Bookshaw/Mr Max Kendrick), winner of this race in 2015 and 2016, stayed on to take a distant second, some 26 lengths adrift, with Treacyswestcounty (Laura Horsfall/Mr Jack Andrews) another half-length back in third.</div>
<div></div>
<div>Brodie Hampson, whose father Mark died last year after a battle with cancer, said: &#8220;It was pretty easy for me really. Ally [Stirling] was unlucky to get injured because it is her ride, but thanks to her she passed it on to me and gave me a dream winner at Cheltenham.</div>
<div></div>
<div>&#8220;The false start did not help because Are They Your Own is very revvy and puts his head on the floor which means he can be difficult to get back.</div>
<div>
&#8220;We were a bit slowly away the second time but I didn&#8217;t panic and he jumped the first two brilliantly and got to the front where we wanted to be.</div>
<div></div>
<div>&#8220;It was a very strong pace and Fergal said to make it a strong pace because we know he stays. He was going to win easily last time over two mile and five furlongs. He likes to bowl along in front and if you try to take him back, he just isn&#8217;t happy.</div>
<div>
&#8220;Obviously, when I won the Royal Artillery for my dad was a big highlight. This would definitely be the second one. I spread some of my dad&#8217;s ashes when I walked the track, so he is here with me.</div>
<div>
&#8220;Riding a winner at Cheltenham is a dream I have been chasing for a while now and finally it has happened.&#8221;</div>
<div></div>
<div>A game performance from <b>Woodfleet</b> (Richard Bandey/Mr Martin McIntyre, 12/1) saw the six-year-old take the honours in the Connolly&#8217;s Red Mills Intermediate Point-To-Point Championship Final Hunters&#8217; Chase (5.40pm) over three and a quarter miles.</div>
<div></div>
<div>A winner of three of his nine starts in point-to-points, Woodfleet took up the running five out and despite being strongly challenged over the last two fences, stayed on courageously to see off the fast-finishing Excitable Island (Nigel Padfield/Miss Gina Andrews, 12/1) by five lengths with Fly West (Ed Walker/Mr Will Biddick, 7/2 Jt Fav) a further length and a half adrift in third.</div>
<div></div>
<div>McIntyre commented: &#8220;I have ridden Woodfleet twice in points and won on him twice. He is a lovely horse, who is very genuine, and I knew he would gallop all the way to the line.</div>
<div></div>
<div>&#8220;I wanted to be handy with a bit of light. I rode him a bit more conservatively because in the first race we went a good gallop and not many of us appeared to get home. He is usually a front-runner, but I wanted to sit in a bit.</div>
<div></div>
<div>&#8220;He is an unbelievable spin. I have ridden him around Larkhill and places like that and he is a joy to ride. Once you get to the front on him, he gallops all the way to the line. He is a super horse.</div>
<div></div>
<div>&#8220;I had my first ride for Enda Bolger at home when I was 21. I am 27 now and didn&#8217;t sit on a horse until I was 18. I had a little discussion with my father about whether to be a carpenter or to ride horses, so to be here today is a dream come true.</div>
<div></div>
<div>&#8220;You are only as good as the horses you are on and I have had great support from the likes of Jack Barber, Richard Bandy and Teresa Clark and every trainer I ride for. I am very grateful for the opportunities.&#8221;</div>
<div></div>
<div>There was a 25/1 upset in the Hunt Stuff Benefit Society Open Hunters&#8217; Chase (6.10pm) over an extended three miles and a furlong, with <b>Knockaderry Flyer</b> (Paul King/Miss Lilly Pinchin) coming home in front.</div>
<div></div>
<div>The eight-year-old faced an ominous-looking challenge from Always Archie (Tim Vaughan/Mr Evan David, 5/2 Fav) three fences from home and the pair drew right away from the rest of the field. The stamina of Knockaderry Flyer won out, as he came home 11 lengths in front of Always Archie, with another 20 lengths back to the third Master Sunrise (Diana Ralph/Mr Leo Mahon, 33/1).</div>
<div></div>
<div>Pinchin commented: &#8220;It is so surreal. I can&#8217;t believe it has actually happened. Since I came out my mum&#8217;s tummy, I have dreamed of riding a winner at Cheltenham!</div>
<div></div>
<div>&#8220;Knockaderry Flyer is a brilliant horse. He travels well and we knew he would stay the trip. I jumped off handy and had to keep taking him back because I did not want him getting too carried away. I then hit the front on the second circuit and let him bowl along &#8211; he was brilliant.</div>
<div></div>
<div>&#8220;We knew he would love the hill because he is used to galloping up all these big hills. He goes up Nigel&#8217;s [Twiston-Davies] gallop so we knew he would definitely stay.</div>
<div></div>
<div>&#8220;I came up through the Pony Club and did a lot of eventing. I had two winners here pony racing which was really lucky. I left school at 15, Fergal [O'Brien] took me on and it has gone on from there really. I had a pointer with Claire Hart and she showed me the ropes.</div>
<div></div>
<div>&#8220;I am still enjoying my pointing but I would love to turn professional. I would need somebody behind me to help me.&#8221;</div>
<div></div>
<div>A superb jumping performance from <b>Frelia</b> (David Gibbs/Mr Bradley Gibbs, 9/1) saw the six-year-old Milan mare power to a hugely-impressive 51-length success in the £6,000 Autovillage Subaru Mares&#8217; Open Hunter Chase (7.20pm) over an extended three miles and a furlong.</div>
<div></div>
<div>Making her debut under Rules, Frelia powered into a clear lead at the top of the hill and the result never looked in doubt. Dabinett Moon (Fran Marriott/Mrs Clare Hardwick, 4/1) taking second with last year&#8217;s winner and 4/5 favourite Popaway (Paul Harkin/Miss Immy Robinson) another eight lengths back in third.</div>
<div></div>
<div>David Gibbs said: &#8220;That was brilliant &#8211; it is a dream come true to have a Cheltenham winner and my son rode it. It is Bradley&#8217;s birthday today, so it&#8217;s celebrations all round.</div>
<div></div>
<div>&#8220;I would like to thank the John Edwards from Cotts vets and Isabel Tompsett. Frelia has been wrong on her last two runs and because of those two people, she is right again. She has won well tonight.</div>
<div></div>
<div>&#8220;She won at Chipley Park earlier in the season and we thought that if she was back to that form, she would have to go close. We were quietly confident. I think there are quite a few people in the Pontrypridd area who had a couple of quid on her so hopefully everyone is happy tonight!</div>
<div></div>
<div>&#8220;She had a muscular problem with her back. When she was second at Garnons, Bradley said she was wrong but I said we had just been beaten by a better horse. Then she was third at Ystradowen and Bradley said she was still wrong. John and Isabel had a look at her and did some treatment &#8211; the rest is history.</div>
<div></div>
<div>&#8220;We bought at Ascot sales as a three-year-old. She is by Oscar and I had always wanted an Oscar. Her grandmother won the Pardubicka twice and something like 34 races in the Czech Republic. That is one of the reasons we bought here. She came from Will Kinsey unbroken. We broke her in and now we have a Cheltenham winner.</div>
<div></div>
<div>&#8220;We will now look at Stratford and Fontwell with her. She is only six and definitely stays in training. Hopefully, there is more improvement to come.&#8221;</div>
<div></div>
<div>The extended four-mile Book Now For The McCoy Awards Hunters&#8217; Chase (7.50pm) went to <b>Dolatulo </b>(Ben Pauling/Mr Dougie Gittins, 6/1).</div>
<div></div>
<div class="simplesocial-box"><div class="simplesocial-title" style="padding-top:10px;margin-bottom:10px;font-size:10pt;font-family:arial;font-weight:bold;">Did you like this? Share it:</div><div style="clear:both"></div><a class=simplesocial onclick="return simplesocial(this,500,400)" title="Share on Facebook" style="background:url(http://racenews.co.uk/wp-content/plugins/simple-social-sharing-widgets-icons-updated/icons_16/facebook.png)" href="http://www.facebook.com/share.php?u=http%3A%2F%2Fracenews.co.uk%2Flaughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening%2F&t=Laughs+just+holds+on+to+take+Timico-sponsored+feature+on+Hunter+Chase+Evening"></a><a class=simplesocial onclick="return simplesocial(this,812,420)" title="Share on Twitter" style="background:url(http://racenews.co.uk/wp-content/plugins/simple-social-sharing-widgets-icons-updated/icons_16/twitter.png)" href="http://twitter.com/home?status=http%3A%2F%2Fracenews.co.uk%2Flaughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening%2F"></a><a class=simplesocial onclick="return simplesocial(this,435,500)" title="Email a Friend" style="background:url(http://racenews.co.uk/wp-content/plugins/simple-social-sharing-widgets-icons-updated/icons_16/email.png)" href="http://www.freetellafriend.com/tell/?heading=Share+This+Article&bg=1&option=email&url=http%3A%2F%2Fracenews.co.uk%2Flaughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening%2F"></a><a class=simplesocial onclick="return simplesocial(this,750,500)" title="Share on Google" style="background:url(http://racenews.co.uk/wp-content/plugins/simple-social-sharing-widgets-icons-updated/icons_16/google.png)" href="http://www.google.com/bookmarks/mark?op=add&bkmk=http%3A%2F%2Fracenews.co.uk%2Flaughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening%2F&title=Laughs+just+holds+on+to+take+Timico-sponsored+feature+on+Hunter+Chase+Evening"></a><div style="clear:both"></div></div><div class="simplesocial-clear" style="clear:both;margin-bottom:20px"></div><div style="clear:both;"></div>
			<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://racenews.co.uk/laughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening/"
    dc:identifier="http://racenews.co.uk/laughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening/"
    dc:title="Laughs just holds on to take Timico-sponsored feature on Hunter Chase Evening"
    trackback:ping="http://racenews.co.uk/laughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening/trackback/" />
</rdf:RDF>
			<div class="postmeta">
				<p>Filed under <a href="http://racenews.co.uk/category/cheltenham/" title="View all posts in Cheltenham" rel="category tag">Cheltenham</a>, <a href="http://racenews.co.uk/category/racenews-live/" title="View all posts in Racenews Live" rel="category tag">Racenews Live</a> &middot; Tagged with </p>
			</div>

		</div>

        <div class="postcomments">
			
<!-- You can start editing here. -->

	
			<!-- If comments are open, but there are no comments. -->

	 


<div id="respond">

<h5>Leave A Comment</h5>

<div class="cancel-comment-reply">
	<small><a rel="nofollow" id="cancel-comment-reply-link" href="/laughs-just-holds-take-timico-sponsored-feature-hunter-chase-evening/#respond" style="display:none;">Click here to cancel reply.</a></small>
</div>


<form action="http://racenews.co.uk/wp-comments-post.php" method="post" id="commentform">


<p><input type="text" name="author" id="author" value="" size="22" tabindex="1" aria-required='true' />
<label for="author"><small>Name (required)</small></label></p>

<p><input type="text" name="email" id="email" value="" size="22" tabindex="2" aria-required='true' />
<label for="email"><small>Mail (will not be published) (required)</small></label></p>

<p><input type="text" name="url" id="url" value="" size="22" tabindex="3" />
<label for="url"><small>Website</small></label></p>


<!--<p><small><strong>XHTML:</strong> You can use these tags: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;strike&gt; &lt;strong&gt; </code></small></p>-->

<p><textarea name="comment" id="comment" cols="100%" rows="10" tabindex="4"></textarea></p>

<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />
<input type='hidden' name='comment_post_ID' value='5485' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>
<input type="hidden" name="9895be6dfbf78214a59564534f3299b4" value="9895be6dfbf78214a59564534f3299b4"/><p id="gasp_p" style="clear:both;"></p><script type="text/javascript">
        //v1.5.1
        var gasp_p = document.getElementById("gasp_p");
        var gasp_cb = document.createElement("input");
        var gasp_text = document.createTextNode(" Confirm you are NOT a spammer");
        gasp_cb.type = "checkbox";
        gasp_cb.id = "cl_check_110";
        gasp_cb.name = "cl_check_110";

        var gasp_label = document.createElement("label");
        gasp_p.appendChild(gasp_label);
        gasp_label.appendChild(gasp_cb);
        gasp_label.appendChild(gasp_text);
        var frm = gasp_cb.form;
        frm.onsubmit = gasp_it;
        function gasp_it(){
        if(gasp_cb.checked != true){
        alert("Please check the box to confirm that you are NOT a spammer");
        return false;
        }
        return true;
        }
        </script>
        <noscript>you MUST enable javascript to be able to comment</noscript>
        <input type="hidden" id="gasp_email" name="gasp_email" value="" />
</form>
</div>


        </div>

		
	</div>

	<div id="sidebar_right">
	<div id="text-4" class="widget widget_text">			<div class="textwidget"></div>
		</div><div id="nav_menu-3" class="widget widget_nav_menu"><h4>By racecourse</h4><div class="menu-racecourses-container"><ul id="menu-racecourses" class="menu"><li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="http://racenews.co.uk/category/aintree/">Aintree</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="http://racenews.co.uk/category/ascot/">Ascot</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15"><a href="http://racenews.co.uk/category/cheltenham/">Cheltenham</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="http://racenews.co.uk/category/doncaster/">Doncaster</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="http://racenews.co.uk/category/epsom/">Epsom</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="http://racenews.co.uk/category/goodwood/">Goodwood</a></li>
<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href="http://racenews.co.uk/category/haydock/">Haydock</a></li>
<li id="menu-item-760" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-760"><a href="http://racenews.co.uk/category/punchestown/">Punchestown</a></li>
</ul></div></div><div id="archives-2" class="widget widget_archive"><h4>By date</h4>		<ul>
			<li><a href='http://racenews.co.uk/2017/05/'>May 2017</a></li>
	<li><a href='http://racenews.co.uk/2017/04/'>April 2017</a></li>
	<li><a href='http://racenews.co.uk/2017/03/'>March 2017</a></li>
	<li><a href='http://racenews.co.uk/2017/02/'>February 2017</a></li>
	<li><a href='http://racenews.co.uk/2017/01/'>January 2017</a></li>
	<li><a href='http://racenews.co.uk/2016/12/'>December 2016</a></li>
	<li><a href='http://racenews.co.uk/2016/11/'>November 2016</a></li>
	<li><a href='http://racenews.co.uk/2016/10/'>October 2016</a></li>
	<li><a href='http://racenews.co.uk/2016/09/'>September 2016</a></li>
	<li><a href='http://racenews.co.uk/2016/08/'>August 2016</a></li>
	<li><a href='http://racenews.co.uk/2016/07/'>July 2016</a></li>
	<li><a href='http://racenews.co.uk/2016/06/'>June 2016</a></li>
	<li><a href='http://racenews.co.uk/2016/05/'>May 2016</a></li>
	<li><a href='http://racenews.co.uk/2016/04/'>April 2016</a></li>
	<li><a href='http://racenews.co.uk/2016/03/'>March 2016</a></li>
	<li><a href='http://racenews.co.uk/2016/02/'>February 2016</a></li>
	<li><a href='http://racenews.co.uk/2016/01/'>January 2016</a></li>
	<li><a href='http://racenews.co.uk/2015/12/'>December 2015</a></li>
	<li><a href='http://racenews.co.uk/2015/11/'>November 2015</a></li>
	<li><a href='http://racenews.co.uk/2015/10/'>October 2015</a></li>
	<li><a href='http://racenews.co.uk/2015/09/'>September 2015</a></li>
	<li><a href='http://racenews.co.uk/2015/08/'>August 2015</a></li>
	<li><a href='http://racenews.co.uk/2015/07/'>July 2015</a></li>
	<li><a href='http://racenews.co.uk/2015/06/'>June 2015</a></li>
	<li><a href='http://racenews.co.uk/2015/05/'>May 2015</a></li>
	<li><a href='http://racenews.co.uk/2015/04/'>April 2015</a></li>
	<li><a href='http://racenews.co.uk/2015/03/'>March 2015</a></li>
	<li><a href='http://racenews.co.uk/2015/02/'>February 2015</a></li>
	<li><a href='http://racenews.co.uk/2015/01/'>January 2015</a></li>
	<li><a href='http://racenews.co.uk/2014/12/'>December 2014</a></li>
	<li><a href='http://racenews.co.uk/2014/11/'>November 2014</a></li>
	<li><a href='http://racenews.co.uk/2014/10/'>October 2014</a></li>
	<li><a href='http://racenews.co.uk/2014/09/'>September 2014</a></li>
	<li><a href='http://racenews.co.uk/2014/08/'>August 2014</a></li>
	<li><a href='http://racenews.co.uk/2014/07/'>July 2014</a></li>
	<li><a href='http://racenews.co.uk/2014/06/'>June 2014</a></li>
	<li><a href='http://racenews.co.uk/2014/05/'>May 2014</a></li>
	<li><a href='http://racenews.co.uk/2014/04/'>April 2014</a></li>
	<li><a href='http://racenews.co.uk/2014/03/'>March 2014</a></li>
	<li><a href='http://racenews.co.uk/2014/02/'>February 2014</a></li>
	<li><a href='http://racenews.co.uk/2014/01/'>January 2014</a></li>
	<li><a href='http://racenews.co.uk/2013/12/'>December 2013</a></li>
	<li><a href='http://racenews.co.uk/2013/11/'>November 2013</a></li>
	<li><a href='http://racenews.co.uk/2013/10/'>October 2013</a></li>
	<li><a href='http://racenews.co.uk/2013/09/'>September 2013</a></li>
	<li><a href='http://racenews.co.uk/2013/08/'>August 2013</a></li>
	<li><a href='http://racenews.co.uk/2013/07/'>July 2013</a></li>
	<li><a href='http://racenews.co.uk/2013/06/'>June 2013</a></li>
	<li><a href='http://racenews.co.uk/2013/05/'>May 2013</a></li>
	<li><a href='http://racenews.co.uk/2013/04/'>April 2013</a></li>
	<li><a href='http://racenews.co.uk/2013/03/'>March 2013</a></li>
	<li><a href='http://racenews.co.uk/2013/02/'>February 2013</a></li>
	<li><a href='http://racenews.co.uk/2013/01/'>January 2013</a></li>
		</ul>
</div><div id="text-3" class="widget widget_text"><h4>Archive (2012 and earlier)</h4>			<div class="textwidget">Please visit <a title="racenews online" href="http://www.racenewsonline.co.uk/" target="_blank">www.racenewsonline.co.uk</a></div>
		</div><div id="text-2" class="widget widget_text"><h4>Twitter</h4>			<div class="textwidget"><a class="twitter-follow-button" href="https://twitter.com/RacenewsService" data-show-count="false" data-lang="en">Follow @RacenewsService</a></div>
		</div><div id="search-2" class="widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="http://racenews.co.uk/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div></div>
	</div>

</div>

<div style="clear:both;"></div>
<!--<div id="logowrapper"><div class="logoholder"><a href="http://www.racenews.co.uk/category/racenews-live/" title="Race News Live"><img src="http://176.32.230.11/racenews.co.uk/wp-content/themes/organic_business/images/racenewslive_NTlogo.png" /></a></div></div>-->
<div id="footerbottom">

	<div id="footerinfo">
         	<div class="footerleft">
        
            <p>© 2017 Racenews &middot; <a href="http://www.onebirddesign.com" target="_blank"> One Bird Design</a> &middot; <a href="http://racenews.co.uk/feed/rss/" target="_blank">RSS Feed</a> &middot; <a rel="nofollow" href="http://racenews.co.uk/wp-login.php">Log in</a></p>
          
        </div>
        
       <div class="footerright">
        <a href="https://twitter.com/RacenewsService" class="twitter-follow-button" data-show-count="false" data-lang="en">Follow @RacenewsService</a>

    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

    	</div>
		
	</div>
	
</div>

</div>

<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/racenews.co.uk\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://racenews.co.uk/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>

</body>
</html>